diff mbox series

[bug#65131,03/32] gnu: Add ruby-net-ftp.

Message ID e109b15ce691aa9fa5c47e9e0d4a8269b35dd8f0.1691432343.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Add vagrant, some vagrant plugins and required ruby modules | expand

Commit Message

Hartmut Goebel Aug. 7, 2023, 6:26 p.m. UTC
* gnu/packages/ruby.scm (ruby-net-ftp): New variable.
---
 gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a0c21c09af..eef586776b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4428,6 +4428,29 @@  address.  Both IPv4 and IPv6 are supported.")
     (home-page "https://github.com/ruby/ipaddr")
     (license license:bsd-2)))
 
+(define-public ruby-net-ftp
+  (package
+    (name "ruby-net-ftp")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)  ;for tests
+              (uri (git-reference
+                    (url "https://github.com/ruby/net-ftp")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "13yb6zalbcizsg592xqlck9xmzqb05pavsfh6ixqlilv4vv7d5ch"))))
+    (build-system ruby-build-system)
+    (propagated-inputs (list ruby-net-protocol ruby-time))
+    (synopsis "File Transfer Protocol client library")
+    (description "This class implements the File Transfer Protocol.  If you
+have used a command-line FTP program, and are familiar with the commands, you
+will be able to use this class easily.  Some extra features are included to
+take advantage of Ruby's style and strengths.")
+    (home-page "https://github.com/ruby/net-ftp")
+    (license license:bsd-2)))
+
 (define-public ruby-net-http-persistent
   (package
     (name "ruby-net-http-persistent")