diff mbox series

[bug#65131,30/32] gnu: Add ruby-fog-xml.

Message ID b902be5c091e51169ea82cbe570ba4d512af3892.1691432343.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Add vagrant, some vagrant plugins and required ruby modules | expand

Commit Message

Hartmut Goebel Aug. 7, 2023, 6:26 p.m. UTC
* gnu/packages/ruby.scm (ruby-fog-xml): New variable.
---
 gnu/packages/ruby.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 50f066e17c..e243f7b81a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9709,6 +9709,41 @@  services library.")
     (home-page "https://github.com/fog/fog-json")
     (license license:expat)))
 
+(define-public ruby-fog-xml
+  (package
+    (name "ruby-fog-xml")
+    (version "0.1.4")
+    (source (origin
+              (method git-fetch)        ; for tests
+              (uri (git-reference
+                    (url "https://github.com/fog/fog-xml")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d0n201qzcjxis5wb26bi3s7yfhlmqkwsl6lb9w4szq3b8l1xbwn"))))
+    (build-system ruby-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; Run tests via bundler so rake picks up the minitest gem from
+          ;; native-inputs, not the one installed otherwise.  This is required
+          ;; since turn@0.9.7 needs minitest@4 and can not be upgraded to
+          ;; minitest@5.
+          (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "bundle" "exec" "rake")))))))
+    (native-inputs (list ruby-minitest-4 ruby-turn ruby-pry ruby-coveralls))
+    (propagated-inputs (list ruby-fog-core ruby-nokogiri))
+    (synopsis "XML parsing tools used by @code{fog} providers")
+    (description "This package containse the XML parsing tools shared between
+a number of providers in the @code{fog} gem.  @code{fog} is a Ruby cloud
+services library.")
+    (home-page "https://github.com/fog/fog-xml")
+    (license license:expat)))
+
 (define-public ruby-pry-byebug
   (package
     (name "ruby-pry-byebug")