diff mbox series

[bug#65131,14/32] gnu: Add ruby-time.

Message ID 564980155dcad017d7d89bf103b9bc9cf0bd1aac.1691432343.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Add vagrant, some vagrant plugins and required ruby modules | expand

Commit Message

Hartmut Goebel Aug. 7, 2023, 6:26 p.m. UTC
* gnu/packages/ruby.scm (ruby-time): New variable.
---
 gnu/packages/ruby.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 98993f6f01..c4ebaa2aaa 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -719,6 +719,29 @@  includes the @code{Comparable} module for handling dates.")
     (home-page "https://github.com/ruby/date")
     (license license:bsd-2)))
 
+(define-public ruby-time
+  (package
+    (name "ruby-time")
+    (version "0.2.2")
+    (source (origin
+              (method git-fetch)  ; for tests
+              (uri (git-reference
+                    (url "https://github.com/ruby/time")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1ij1vfa5vlphnv2giji71nbsj07yfghyvw4vhmsizxm8nmlqasl6"))))
+    (build-system ruby-build-system)
+    (propagated-inputs (list ruby-date))
+    (synopsis
+     "Extends the Time class with methods for parsing and conversion")
+    (description
+     "When this gem is @code{require}d, it extends the Time class with with
+additional methods for parsing and converting Times.")
+    (home-page "https://github.com/ruby/time")
+    (license license:bsd-2)))
+
 (define-public ruby-diff-lcs
   (package
     (name "ruby-diff-lcs")