diff mbox series

[bug#65131,21/32] gnu: Add ruby-hashicorp-checkpoint.

Message ID 71c3cece5f3375da93eb98155c878aca25892a07.1691432343.git.h.goebel@crazy-compilers.com
State New
Headers show
Series Add vagrant, some vagrant plugins and required ruby modules | expand

Commit Message

Hartmut Goebel Aug. 7, 2023, 6:26 p.m. UTC
* gnu/packages/ruby.scm (ruby-hashicorp-checkpoint): New variable.
---
 gnu/packages/ruby.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0bcf61d15b..0ee9d447a1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9589,6 +9589,26 @@  follows Ruby conventions and requires little knowledge of REST.")
     (home-page "https://github.com/octokit/octokit.rb")
     (license license:expat)))
 
+(define-public ruby-hashicorp-checkpoint
+  (package
+    (name "ruby-hashicorp-checkpoint")
+    (version "0.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "hashicorp-checkpoint" version))
+              (sha256
+               (base32
+                "1z6mwzvd7p2wqhmk07dwrhvm0ncgqm7pxn0pr2k025rwsspp9bsd"))))
+    (build-system ruby-build-system)
+    (arguments
+     (list #:tests? #f)) ;; no need to test, useless outside HashiCorp anyway
+    (synopsis "Internal HashiCorp service to check version information")
+    (description "This package is probably useless outside of internal
+HashiCorp use.  It is open source for disclosure and because HashiCorp's open
+source projects must be able to link to it.")
+    (home-page "https://github.com/hashicorp/ruby-checkpoint")
+    (license license:mpl2.0)))
+
 (define-public ruby-vagrant-cloud
   (package
     (name "ruby-vagrant-cloud")