diff mbox series

[bug#64916,v2,19/23] gnu: Add go-github-com-pelletier-go-toml-v2.

Message ID d87b7e89c0ffcdcb890ed7233dd4bd69995eed12.1690564476.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 5:20 p.m. UTC
* gnu/packages/golang.scm (go-github-com-pelletier-go-toml-v2): New variable.
---
 gnu/packages/golang.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 60f9d79177..1cb1c8f304 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5235,6 +5235,26 @@  (define-public go-github-com-pelletier-go-toml
     (description "Go library for the TOML configuration language")
     (license license:expat)))
 
+(define-public go-github-com-pelletier-go-toml-v2
+  (package
+    (inherit go-github-com-pelletier-go-toml)
+    (name "go-github-com-pelletier-go-toml-v2")
+    (version "2.0.8")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pelletier/go-toml")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "04lbwawyvygzzy5w4c9bs8jywr1ypm35zb4cp477gxl1iiqvzk54"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/pelletier/go-toml/v2"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))))
+
 (define-public go-github-com-subosito-gotenv
   (package
     (name "go-github-com-subosito-gotenv")