diff mbox series

[bug#64916,v2,14/23] gnu: Add go-github-com-go-playground-assert-v2.

Message ID ccf35f8b06e5574c37cb59e9b39186c95d02d89d.1690564476.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 5:20 p.m. UTC
* gnu/packages/golang.scm (go-github-com-go-playground-assert-v2): New
variable.
---
 gnu/packages/golang.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 425afc9a6b..6a5f111824 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3037,6 +3037,23 @@  (define-public go-gopkg-in-go-playground-assert-v1
 custom assertions to be used alongside native Go testing.")
     (license license:expat)))
 
+(define-public go-github-com-go-playground-assert-v2
+  (package
+    (inherit go-gopkg-in-go-playground-assert-v1)
+    (name "go-github-com-go-playground-assert-v2")
+    (version "2.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-playground/assert")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1cl9c4s405zddzrj36hhs0a18g02zscdl46fyipp6k91mhvai8wz"))))
+    (arguments
+     (list #:import-path "github.com/go-playground/assert/v2"))))
+
 (define-public go-github-com-go-playground-locales
   (package
     (name "go-github-com-go-playground-locales")