diff mbox series

[bug#64916,v2,15/23] gnu: Add go-github-com-go-playground-validator-v10.

Message ID 7fd422533410195ce6af7cb605efc1bccc00efb4.1690564476.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 5:20 p.m. UTC
* gnu/packages/golang.scm (go-github-com-go-playground-validator-v10): New
variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6a5f111824..0dbd94592f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3173,6 +3173,30 @@  (define-public go-gopkg-in-go-playground-validator-v9
 @end itemize")
     (license license:expat)))
 
+(define-public go-github-com-go-playground-validator-v10
+  (package
+    (inherit go-gopkg-in-go-playground-validator-v9)
+    (name "go-github-com-go-playground-validator-v10")
+    (version "10.11.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-playground/validator")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03sd3gd3pl2bv07ivrixp3h5hrw1d1llrpjdalh9jbgby0x2f8ig"))))
+    (arguments
+     (list #:import-path "github.com/go-playground/validator/v10"))
+    (propagated-inputs
+     (modify-inputs (package-propagated-inputs
+                     go-gopkg-in-go-playground-validator-v9)
+       (append go-golang-org-x-crypto
+               go-golang-org-x-text)))
+    (native-inputs
+     (list go-github-com-go-playground-assert-v2))))
+
 (define-public go-github-com-nathan-osman-go-sunrise
   (let ((commit "c8f9f1eb869135f07378e7e3c5ec7a005f806c73")
         (revision "0"))