diff mbox series

[bug#64916,v2,04/23] gnu: Add go-github-com-alecthomas-assert-v2.

Message ID d3bcce7db6b3f6fef11d01c9f06de82f29503543.1690564476.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 5:19 p.m. UTC
* gnu/packages/golang.scm (go-github-com-alecthomas-assert-v2): New variable.
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 749f058b79..1081827195 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9163,6 +9163,28 @@  (define-public go-github-com-alecthomas-assert
 @end itemize\n")
       (license license:expat))))
 
+(define-public go-github-com-alecthomas-assert-v2
+  (package
+    (inherit go-github-com-alecthomas-assert)
+    (name "go-github-com-alecthomas-assert-v2")
+    (version "2.2.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alecthomas/assert")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "055w46gr47rrn5g2hh7z6hj3x2b8advbcph8gs8szrpzlympyyz0"))))
+    (arguments
+     (list #:go go-1.18
+           #:import-path "github.com/alecthomas/assert/v2"))
+    (propagated-inputs
+     (list go-github-com-alecthomas-repr
+           go-github-com-hexops-gotextdiff))
+    (native-inputs '())))
+
 (define-public go-github-com-alecthomas-chroma
   (package
     (name "go-github-com-alecthomas-chroma")