diff mbox series

[bug#64916,v2,03/23] gnu: go-github-com-alecthomas-repr: Update to 0.2.0.

Message ID 9548780f1dcdfc244aa21f25a9f94db229aa31ed.1690564476.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 5:19 p.m. UTC
* gnu/packages/golang.scm (go-github-com-alecthomas-repr): Update to 0.2.0.
[arguments]<#:go>: Use go-1.18.
---
 gnu/packages/golang.scm | 45 ++++++++++++++++++++---------------------
 1 file changed, 22 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f81a330697..749f058b79 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9078,30 +9078,29 @@  (define-public go-github-com-alecthomas-colour
     (license license:expat)))
 
 (define-public go-github-com-alecthomas-repr
-  (let ((commit "4184120f674c8860a5b48142509a2411a0a1766f")
-        (revision "1"))
-    (package
-      (name "go-github-com-alecthomas-repr")
-      (version (git-version "0.0.1" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/alecthomas/repr")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1z0gdkjryxg1ps5fh4ybzip27g9lzdldz4hxqp5j7s2frbzaa9s7"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "github.com/alecthomas/repr"))
-      (native-inputs
-       (list go-github-com-stretchr-testify))
-      (home-page "https://github.com/alecthomas/repr/")
-      (synopsis "Represent Go values in an almost direct form")
-      (description "This package attempts to represent Go values in a form that
+  (package
+    (name "go-github-com-alecthomas-repr")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alecthomas/repr")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0pryj28l9rvin58sg5amj8izp613k7pymrmd7pdp7zpl9xjvhyxq"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:go ,go-1.18
+       #:import-path "github.com/alecthomas/repr"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/alecthomas/repr/")
+    (synopsis "Represent Go values in an almost direct form")
+    (description "This package attempts to represent Go values in a form that
 can be used almost directly in Go source code.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public go-github-com-sergi-go-diff
   (package