diff mbox series

[bug#47539,v2,06/26] gnu: Add go-github-com-makenowjust-heredoc.

Message ID c9b263d181755176a2b0d6ed4688a7c29a442c6d.1617301221.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 1, 2021, 6:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-makenowjust-heredoc): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 268a88e15b..b1e9baf85b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7185,3 +7185,27 @@  sending input through it's pseudoterminal.")
 terminals supporting ANSI escape sequences.")
     (license license:expat)))
 
+(define-public go-github-com-makenowjust-heredoc
+  (package
+    (name "go-github-com-makenowjust-heredoc")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/MakeNowJust/heredoc.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "18f21zm8n2wlnkz1ylw8rcxmqxyv2rlz8749yfqggm2m0m2884pj"))))
+    (build-system go-build-system)
+    (arguments
+      '(#:import-path "github.com/MakeNowJust/heredoc"))
+    (home-page
+      "https://github.com/MakeNowJust/heredoc")
+    (synopsis "Here-documents with keeping indent")
+    (description "This package provides the Here-document with keeping
+indent.")
+    (license license:expat)))
+