diff mbox series

[bug#47539,v2,04/26] gnu: Add go-github-com-netflix-go-expect.

Message ID 56a4bc352acaf29d13b0607c450aa581f5203b1c.1617301221.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 1, 2021, 6:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-netflix-go-expect): New variable.
---
 gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6664e28e8f..57ae6e3210 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7106,3 +7106,33 @@  larged been influenced by st, rxvt, xterm, and iTerm as reference.")
      (description "Pty is a Go package for using Unix pseudo-terminals.")
      (license license:expat))))
 
+(define-public go-github-com-netflix-go-expect
+  (package
+    (name "go-github-com-netflix-go-expect")
+    (version "0.0.0-20201125194554-85d881c3777e")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/Netflix/go-expect.git")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "01s59hsdwy2nngngcgzyhncys56pdgzr6lff7k8kjrh26zk6pdv5"))))
+    (build-system go-build-system)
+    (arguments
+      '(#:import-path "github.com/Netflix/go-expect"))
+    (native-inputs
+      `(("go-github-com-stretchr-testify"
+         ,go-github-com-stretchr-testify)
+        ("go-github-com-kr-pty" ,go-github-com-kr-pty)))
+    (home-page
+      "https://github.com/Netflix/go-expect")
+    (synopsis "Expect-like library to automate control of terminal programs")
+    (description "This package provides an expect-like interface to automate
+control of applications.  It is unlike expect in that it does not spawn or
+manage process lifecycle.  This package only focuses on expecting output and
+sending input through it's pseudoterminal.")
+    (license license:asl2.0)))
+