diff mbox series

[bug#47539,v2,25/26] gnu: Add go-github-com-cli-shurcool-graphql.

Message ID 63f804a2f569ce800a1dade485c80bb395a4fd0a.1617301221.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 1, 2021, 6:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-cli-shurcool-graphql): New variable.
---
 gnu/packages/golang.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f220eca4ac..4ca2f280f9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7712,3 +7712,22 @@  library to parse and generate YAML data quickly and reliably.")
     (description "This package provides a GraphQL client implementation.")
     (license license:expat)))
 
+;; GitHub's fork of go-github-com-shurcool-graphql, used by the 'github-cli'
+(define-public go-github-com-cli-shurcool-graphql
+  (hidden-package
+   (package
+     (inherit go-github-com-shurcool-graphql)
+     (name "go-github-com-cli-shurcool-graphql")
+     ;; Use the commit from the 'named-queries' branch
+     (version "0.0.0-20200707151639-0f7232a2bf7e")
+     (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/cli/shurcooL-graphql.git")
+              (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "19dv1zprs9zv5gnwql29r7lym08gh2jwkz0w0f62823b57m1rjp6"))))
+     (home-page "https://github.com/cli/shurcooL-graphql"))))