diff mbox series

[bug#47539,v2,05/26] gnu: Add go-github-com-alecaivazis-survey-v2.

Message ID 1caaa23be675d3c7d9245b5d2d3d8258d99631d9.1617301221.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 1, 2021, 6:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-alecaivazis-survey-v2): New variable.
---
 gnu/packages/golang.scm | 49 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 57ae6e3210..268a88e15b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -63,6 +63,7 @@ 
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages textutils)
+  #:use-module ((gnu packages syncthing) #:select (go-github-com-kballard-go-shellquote))
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (ice-9 match)
@@ -7136,3 +7137,51 @@  manage process lifecycle.  This package only focuses on expecting output and
 sending input through it's pseudoterminal.")
     (license license:asl2.0)))
 
+(define-public go-github-com-alecaivazis-survey-v2
+  (package
+    (name "go-github-com-alecaivazis-survey-v2")
+    (version "2.2.9")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/AlecAivazis/survey.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1jw4ka44q7a2885fil4qnb56mdlixmy5ysd68i5h5dblbq4r61l1"))))
+    (build-system go-build-system)
+    (arguments
+      '(#:import-path "github.com/AlecAivazis/survey"))
+    (native-inputs
+      `(("go-golang-org-x-text" ,go-golang-org-x-text)
+        ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+        ("go-golang-org-x-crypto"
+         ,go-golang-org-x-crypto)
+        ("go-github-com-stretchr-testify"
+         ,go-github-com-stretchr-testify)
+        ("go-github-com-pmezard-go-difflib"
+         ,go-github-com-pmezard-go-difflib)
+        ("go-github-com-mgutz-ansi"
+         ,go-github-com-mgutz-ansi)
+        ("go-github-com-mattn-go-isatty"
+         ,go-github-com-mattn-go-isatty)
+        ("go-github-com-mattn-go-colorable"
+         ,go-github-com-mattn-go-colorable)
+        ("go-github-com-kr-pty" ,go-github-com-kr-pty)
+        ("go-github-com-kballard-go-shellquote"
+         ,go-github-com-kballard-go-shellquote)
+        ("go-github-com-hinshun-vt10x"
+         ,go-github-com-hinshun-vt10x)
+        ("go-github-com-davecgh-go-spew"
+         ,go-github-com-davecgh-go-spew)
+        ("go-github-com-netflix-go-expect"
+         ,go-github-com-netflix-go-expect)))
+    (home-page
+      "https://github.com/AlecAivazis/survey")
+    (synopsis "Build interactive prompts on terminals")
+    (description "This is a library for building interactive prompts on
+terminals supporting ANSI escape sequences.")
+    (license license:expat)))
+