[bug#47539,v2,00/26] Add github-cli and dependencies

Message ID cover.1617301221.git.public@yoctocell.xyz
Headers show
Series Add github-cli and dependencies | expand

Message

Xinglu Chen April 1, 2021, 6:31 p.m. UTC
Changes since v1:

- Renamed 'gh' to 'github-cli' to avoid short two or three letter names.

- Added a phase in 'github-cli' to remove its dependence on the
  'go-github-com-cli-safeexec' package, and I also removed
  'go-github-com-cli-safeexec' itself since it is only used on Windows.

- Removed 'go-github-com-shurcool-sanitized-anchor-name' because it
  already existed.  Upstream uses '_' instead of '-' in the name, the Go
  importer didn't convert '_' to '-' so I had to fix it myself without
  realizing that the package already existed.
  
- Marked 'go-github-com-cli-shurcool-graphql' as a hidden package
  because it is GitHub's own fork of 'go-github-com-shurcool-graphql',
  and is only used by 'github-cli'.
  
Xinglu Chen (26):
  gnu: Add go-github-com-hinshun-vt10x.
  gnu: Add go-github-com-creack-pty.
  gnu: Add go-github-com-kr-pty.
  gnu: Add go-github-com-netflix-go-expect.
  gnu: Add go-github-com-alecaivazis-survey-v2.
  gnu: Add go-github-com-makenowjust-heredoc.
  gnu: Add go-github-com-briandowns-spinner.
  gnu: Add go-github-com-cli-browser.
  gnu: Add go-github-com-cli-oauth.
  gnu: Add go-github-com-cli-safeexec.
  gnu: Add go-github-com-russross-blackfriday-v2.
  gnu: Add go-github-com-cpuguy83-go-md2man-v2.
  gnu: Add go-github-com-enescakir-emoji.
  gnu: Add go-github-com-gabriel-vasile-mimetype.
  gnu: Add go-github-com-google-shlex.
  gnu: Add go-github-com-henvic-httpretty.
  gnu: Add go-github-com-itchyny-go-flags.
  gnu: Add go-github-com-itchyny-timefmt-go.
  gnu: Add go-github-com-itchyny-gojq.
  gnu: Add go-github-com-mattn-go-runewidth.
  gnu: Add go-github-com-rivo-uniseg.
  gnu: Add go-github-com-shurcool-githubv4.
  gnu: Add go-gopkg-in-yaml-v3.
  gnu: Add go-github-com-shurcool-graphql.
  gnu: Add go-github-com-cli-shurcool-graphql.
  gnu: Add github-cli.

 gnu/packages/golang.scm          | 697 +++++++++++++++++++++++++++++++
 gnu/packages/version-control.scm | 145 +++++++
 2 files changed, 842 insertions(+)


base-commit: 9c9a36de732ea8485e47e84b888e121233f68452

Comments

Xinglu Chen April 19, 2021, 1:24 p.m. UTC | #1
Friendly ping! :)
Leo Prikler April 19, 2021, 2:15 p.m. UTC | #2
Am Montag, den 19.04.2021, 15:24 +0200 schrieb Xinglu Chen:
> Friendly ping! :)
I think you fixed most of my concerns from the previous run, but
looking at Patchwork, there appear to still be a few issues:

1. Some patches don't seem to apply correctly over at Patchwork [1]. 
This can perhaps be ignored, as it seems to be an issue with patches
being received out of order and the last one applies cleanly.
2. The corresponding revision fails to build [2].
3. The patch for safeexec still seems to be part of the series even
though it's unused.  Didn't you mean to exclude that one?

Again, I'm not really familiar with the Go side of things, so while as
a reviewer I can point out stuff, that is not aesthetically pleasing,
as a committer I'm somewhat forced to trust what the CI tells me.  I
would personally feel more reassured if someone with a bit of Go
experience had a look at this patch set, but judging from the 2 weeks
of silence, it seems they are all sleeping or silently trusting me to
do a good job.

Regards,
Leo

[1] 
https://patches.guix-patches.cbaines.net/project/guix-patches/list/?series=7514
[2] https://data.guix-patches.cbaines.net/job/12256
Xinglu Chen April 19, 2021, 2:39 p.m. UTC | #3
On Mon, Apr 19 2021, Leo Prikler wrote:

> Am Montag, den 19.04.2021, 15:24 +0200 schrieb Xinglu Chen:
>> Friendly ping! :)
> I think you fixed most of my concerns from the previous run, but
> looking at Patchwork, there appear to still be a few issues:
>
> 1. Some patches don't seem to apply correctly over at Patchwork [1]. 
> This can perhaps be ignored, as it seems to be an issue with patches
> being received out of order and the last one applies cleanly.

Hmm, they applied on my local checkout, maybe it’s something to do with
the order.

> 2. The corresponding revision fails to build [2].

I will look into that.

> 3. The patch for safeexec still seems to be part of the series even
> though it's unused.  Didn't you mean to exclude that one?

Oops, not sure what I did there, it should be removed.

> Again, I'm not really familiar with the Go side of things, so while as
> a reviewer I can point out stuff, that is not aesthetically pleasing,
> as a committer I'm somewhat forced to trust what the CI tells me.  I
> would personally feel more reassured if someone with a bit of Go
> experience had a look at this patch set, but judging from the 2 weeks
> of silence, it seems they are all sleeping or silently trusting me to
> do a good job.

Understood, thanks for taking a look!
Xinglu Chen April 19, 2021, 3:21 p.m. UTC | #4
Changes since v2:

- Actually remove go-github-com-cli-safeexec

Xinglu Chen (25):
  gnu: Add go-github-com-hinshun-vt10x.
  gnu: Add go-github-com-creack-pty.
  gnu: Add go-github-com-kr-pty.
  gnu: Add go-github-com-netflix-go-expect.
  gnu: Add go-github-com-alecaivazis-survey-v2.
  gnu: Add go-github-com-makenowjust-heredoc.
  gnu: Add go-github-com-briandowns-spinner.
  gnu: Add go-github-com-cli-browser.
  gnu: Add go-github-com-cli-oauth.
  gnu: Add go-github-com-russross-blackfriday-v2.
  gnu: Add go-github-com-cpuguy83-go-md2man-v2.
  gnu: Add go-github-com-enescakir-emoji.
  gnu: Add go-github-com-gabriel-vasile-mimetype.
  gnu: Add go-github-com-google-shlex.
  gnu: Add go-github-com-henvic-httpretty.
  gnu: Add go-github-com-itchyny-go-flags.
  gnu: Add go-github-com-itchyny-timefmt-go.
  gnu: Add go-github-com-itchyny-gojq.
  gnu: Add go-github-com-mattn-go-runewidth.
  gnu: Add go-github-com-rivo-uniseg.
  gnu: Add go-github-com-shurcool-githubv4.
  gnu: Add go-gopkg-in-yaml-v3.
  gnu: Add go-github-com-shurcool-graphql.
  gnu: Add go-github-com-cli-shurcool-graphql.
  gnu: Add github-cli.

 gnu/packages/golang.scm          | 672 +++++++++++++++++++++++++++++++
 gnu/packages/version-control.scm | 145 +++++++
 2 files changed, 817 insertions(+)


base-commit: 1eb26d0e07ad439c935b324c1ed858f50e9dcccd