diff mbox series

[bug#47539,v3,09/25] gnu: Add go-github-com-cli-oauth.

Message ID c92d51ce333075f87b3fca409ca94cf0fee947b0.1618845645.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 19, 2021, 3:22 p.m. UTC
* gnu/packages/golang.scm (go-github-com-cli-oauth): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 17ea7dc210..f250571c38 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7262,3 +7262,29 @@  indicator to any terminal application. ")
 files in the system default web browser.")
     (license license:bsd-2)))
 
+(define-public go-github-com-cli-oauth
+  (package
+    (name "go-github-com-cli-oauth")
+    (version "0.8.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/cli/oauth.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1b96cl53qc40xsgpxpy9qkrib4a4g02a4sq442qp8749qab5ljhs"))))
+    (build-system go-build-system)
+    (arguments
+      '(#:import-path "github.com/cli/oauth"))
+    (native-inputs
+      `(("go-github-com-cli-browser"
+         ,go-github-com-cli-browser)))
+    (home-page "https://github.com/cli/oauth")
+    (synopsis "Perform OAuth Device flow and Web application flow in Go")
+    (description "This is a library for performing OAuth Device flow and Web
+application flow in Go client apps.")
+    (license license:expat)))
+