diff mbox series

[bug#47539,v3,19/25] gnu: Add go-github-com-mattn-go-runewidth.

Message ID c60d79e7d55a0345de6809d9e983386e1c09dbd1.1618845646.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 19, 2021, 3:23 p.m. UTC
* gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8327e328a0..9e3d9174c1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7555,3 +7555,29 @@  command written in Go language.  It is also embedable as a library to other Go
 projects.")
     (license license:expat)))
 
+(define-public go-github-com-mattn-go-runewidth
+  (package
+    (name "go-github-com-mattn-go-runewidth")
+    (version "0.0.10")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/mattn/go-runewidth.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0jh9552ppqvkdfni7x623n0x5mbiaqqhjhmr0zkh28x56k4ysii4"))))
+    (build-system go-build-system)
+    (arguments
+      '(#:import-path "github.com/mattn/go-runewidth"))
+    (native-inputs
+      `(("go-github-com-rivo-uniseg"
+         ,go-github-com-rivo-uniseg)))
+    (home-page "https://github.com/mattn/go-runewidth")
+    (synopsis "Functions to get fixed width of the character or string")
+    (description "This package provides functions to get fixed width of the
+character or string.")
+    (license license:expat)))
+