diff mbox series

[bug#47539,v3,13/25] gnu: Add go-github-com-gabriel-vasile-mimetype.

Message ID 1bcd355c58e0f9eb20973ca783fec866c11005af.1618845646.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 19, 2021, 3:23 p.m. UTC
* gnu/packages/golang.scm (go-github-com-gabriel-vasile-mimetype): New variable.
---
 gnu/packages/golang.scm | 47 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 289685ef4c..7dfc098480 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7367,3 +7367,50 @@  substitutions, etc.), and it is safe for all utf-8 (unicode) input.")
 Go.  It lets you use emoji characters in strings.")
     (license license:expat)))
 
+(define-public go-github-com-gabriel-vasile-mimetype
+  (package
+    (name "go-github-com-gabriel-vasile-mimetype")
+    (version "1.2.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/gabriel-vasile/mimetype.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0ysb0pjhyr9b7q2y39b5hpwsaidgfl42gd07yj34mgmb9wfjb7ch"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path
+       "github.com/gabriel-vasile/mimetype"
+       ;; FIXME: Cannot open 'supported_mimes.md'
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         ;; The files are read-only
+         (add-before 'reset-gzip-timestamps 'make-gz-files-writable
+           (lambda* (#:key outputs #:allow-other-keys)
+             (for-each make-file-writable
+                       (find-files (string-append (assoc-ref outputs "out"))
+                                   ".*\\.gz$"))
+             #t)))))
+
+    (home-page
+      "https://github.com/gabriel-vasile/mimetype")
+    (synopsis "A fast golang library for MIME type and file extension detection")
+    (description "This is a package for detecting MIME types and extensions
+based on magic numbers.  Features include
+
+@itemize
+@item fast and precise MIME type and file extension detection
+@item long list of supported MIME types
+@item common file formats are prioritized
+@item small and simple API
+@item handles MIME type aliases
+@item thread safe
+@item low memory usage, besides the file header
+@end itemize")
+    (license license:expat)))
+