diff mbox series

[bug#47539,v3,22/25] gnu: Add go-gopkg-in-yaml-v3.

Message ID c6c15bf035b2f1f3aceaca374e2e3816b78e777c.1618845646.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 19, 2021, 3:23 p.m. UTC
* gnu/packages/golang.scm (go-gopkg-in-yaml-v3): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a2f2bf45c9..9182fb183f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7636,3 +7636,29 @@  GraphQL API v4.  It focuses on the following things:
 @end itemize")
     (license license:expat)))
 
+(define-public go-gopkg-in-yaml-v3
+  (package
+    (name "go-gopkg-in-yaml-v3")
+    (version "3.0.0-20210107192922-496545a6307b")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://gopkg.in/yaml.v3")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "06f4lnrp494wqaygv09dggr2dwf3z2bawqhnlnnwiamg5y787k4g"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "gopkg.in/yaml.v3"))
+    (native-inputs
+      `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+    (home-page "https://gopkg.in/yaml.v3")
+    (synopsis "YAML support for the Go language")
+    (description "This library enables Go programs to comfortably encode and
+decode YAML values.  It is based on a pure Go port of the well-known libyaml C
+library to parse and generate YAML data quickly and reliably.")
+    (license (list license:expat
+                   license:asl2.0))))
+