diff mbox series

[bug#47539,v3,24/25] gnu: Add go-github-com-cli-shurcool-graphql.

Message ID 667ee0352f33503cc950ba70ccf714a0123ba705.1618845646.git.public@yoctocell.xyz
State New
Headers show
Series Add github-cli and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 19, 2021, 3:24 p.m. UTC
* gnu/packages/golang.scm (go-github-com-cli-shurcool-graphql): New variable.
---
 gnu/packages/golang.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b4195d1c6f..642b364bcd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7686,3 +7686,22 @@  library to parse and generate YAML data quickly and reliably.")
     (description "This package provides a GraphQL client implementation.")
     (license license:expat)))
 
+;; GitHub's fork of go-github-com-shurcool-graphql, used by the 'github-cli'
+(define-public go-github-com-cli-shurcool-graphql
+  (hidden-package
+   (package
+     (inherit go-github-com-shurcool-graphql)
+     (name "go-github-com-cli-shurcool-graphql")
+     ;; Use the commit from the 'named-queries' branch
+     (version "0.0.0-20200707151639-0f7232a2bf7e")
+     (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/cli/shurcooL-graphql.git")
+              (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "19dv1zprs9zv5gnwql29r7lym08gh2jwkz0w0f62823b57m1rjp6"))))
+     (home-page "https://github.com/cli/shurcooL-graphql"))))