diff mbox series

[bug#65280,v2,26/59] gnu: qt-creator: Update to 11.0.1.

Message ID c11bdf3aaa2f6ff9476f4303025ae642e14e9da7.1692187578.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Refresh Qt 5 and 6 packages | expand

Commit Message

Maxim Cournoyer Aug. 16, 2023, 12:10 p.m. UTC
* gnu/packages/qt.scm (qt-creator): Update to 11.0.1.
[source]: Adjust snippet.
[arguments]: Adjust patch-paths phase.  Disable the 'tst_process' failing
tests.

---

Changes in v2:
- Delete fix-tests-build phase
- Only one new test is now disabled

 gnu/packages/qt.scm | 35 +++++++++++++++++++----------------
 1 file changed, 19 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0d84231cef..c858bab571 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4820,7 +4820,7 @@  (define-public clazy
 (define-public qt-creator
   (package
     (name "qt-creator")
-    (version "9.0.0")
+    (version "11.0.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -4834,7 +4834,6 @@  (define-public qt-creator
                            ;; Remove bundled libraries, where supported.
                            ;; TODO: package and unbundle litehtml
                            '("src/libs/3rdparty/yaml-cpp"
-                             "src/shared/qbs/src/shared/qtscript/src/3rdparty"
                              "tests/unit/unittest/3rdparty"
                              ;; Marketplace recommends nonfree extensions;
                              ;; remove it.
@@ -4845,7 +4844,7 @@  (define-public qt-creator
                             ((".*marketplace/marketplace.qbs.*") ""))))
               (sha256
                (base32
-                "1adyxs0cnqx14gwzkvh909c52449ia6y87n1r4qf6wwydhch43cs"))))
+                "0j90dv9micqsvj4r7iqd11szixr0mlpna4w5s2lnyqckjs6a0mm6"))))
     (build-system qt-build-system)
     (arguments
      (list
@@ -4861,25 +4860,17 @@  (define-public qt-creator
                              #$output "/lib/qtcreator"))
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'fix-tests-build
-            (lambda _
-              ;; Add a missing link directive (see:
-              ;; https://bugreports.qt.io/browse/QTCREATORBUG-28434).
-              (substitute* "src/libs/tracing/CMakeLists.txt"
-                (("DEPENDS Utils Qt5::Qml Qt5::Quick")
-                 "DEPENDS Utils Qt5::Quick")
-                (("PUBLIC_DEPENDS Qt5::Widgets")
-                 "PUBLIC_DEPENDS Qt5::Widgets Qt5::Qml"))))
           (add-after 'unpack 'patch-paths
             (lambda* (#:key inputs #:allow-other-keys)
               (substitute* '("src/libs/utils/commandline.cpp"
                              "src/libs/utils/deviceshell.cpp")
                 (("/bin/sh")
                  (search-input-file inputs "bin/sh")))
-              (substitute* "src/libs/utils/qtcprocess.cpp"
+              (substitute* "src/libs/utils/process.cpp"
                 (("/usr/bin/env")
                  (search-input-file inputs "bin/env")))
-              (substitute* "tests/auto/utils/qtcprocess/tst_qtcprocess.cpp"
+              (substitute* '("tests/auto/utils/process/tst_process.cpp"
+                             "tests/auto/utils/commandline/tst_commandline.cpp")
                 (("/bin/sh")
                  (which "sh")))))
           (add-before 'build 'build-doc
@@ -4892,7 +4883,6 @@  (define-public qt-creator
               (invoke "cmake" "--install" "." "--prefix" #$output
                       "--component=html_docs")))
           (replace 'check
-            ;; Loosely based on .github/workflows/build_cmake.yml.
             (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
               (when tests?
                 (invoke "xvfb-run"      ;for the 'renderpass' tests
@@ -4900,7 +4890,20 @@  (define-public qt-creator
                                          (number->string (parallel-job-count))
                                          "1")
                         "--label-exclude" "exclude_from_precheck"
-                        "--exclude-regex" "tst_perfdata"))))
+                        "-E"
+                        (string-append
+                         "("
+                         (string-join
+                          (list
+                           ;; The performance data tests require external
+                           ;; data.
+                           "tst_perfdata"
+                           ;; This test relies on counting processes, counts
+                           ;; only 0 of them instead of 5 for unknown reasons
+                           ;; (see:
+                           ;; https://bugreports.qt.io/browse/QTCREATORBUG-29495).
+                           "tst_process") "|")
+                         ")")))))
           (add-after 'qt-wrap 'wrap-bin
             ;; Make a few well-integrated tools readily available.
             (lambda* (#:key inputs outputs #:allow-other-keys)