diff mbox series

[bug#65280,v2,04/59] gnu: qtbase: Update to 6.5.2.

Message ID 1176b1ea6a93417dbbca2638145e0f74e5e1da47.1692187578.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Refresh Qt 5 and 6 packages | expand

Commit Message

Maxim Cournoyer Aug. 16, 2023, 12:10 p.m. UTC
* gnu/packages/qt.scm (qtbase): Update to 6.5.2.  Use normal inheritance, not
package/inherit, as the package is distinct and not a variant (it does not use
the same source).
[arguments]: Disable a few newly failing tests in the check phase.  Adjust the
patch-mkspecs phase.
[inputs]: Remove extraneous postgresql replacement.  Add at-spi2-core, libice,
libsm, libxext and xcb-util-cursor.

---

Changes in v2:
- Fix xcb backend by adding missing inputs

 gnu/packages/qt.scm | 33 ++++++++++++++++++++++++++-------
 1 file changed, 26 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index a4de003647..03c9256a48 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -581,15 +581,16 @@  (define-public qtbase-5
     (license (list license:lgpl2.1 license:lgpl3))))
 
 (define-public qtbase
-  (package/inherit qtbase-5
+  (package
+    (inherit qtbase-5)
     (name "qtbase")
-    (version "6.3.2")
+    (version "6.5.2")
     (source (origin
               (inherit (package-source qtbase-5))
               (uri (qt-url name version))
               (sha256
                (base32
-                "19m9r8sf9mvyrwipn44if3nhding4ljys2mwf04b7dkhz16vlabr"))
+                "0s8jwzdcv97dfy8n3jjm8zzvllv380l73mwdva7rs2nqnhlwgd1x"))
               (modules '((guix build utils)))
               (snippet
                ;; corelib uses bundled harfbuzz, md4, md5, sha3
@@ -742,6 +743,18 @@  (define-public qtbase
                      (list
                       ;; The 'tst_moc' test fails with "'fi.exists()' returned FALSE".
                       "tst_moc"
+
+                      ;; The 'tst_qdate' test fails because the current time
+                      ;; is reported as an invalid date (see:
+                      ;; https://bugreports.qt.io/browse/QTBUG-116017).
+                      "tst_qdate"
+
+                      ;; The qgraphicsview and qopenglwidget tests fail with a
+                      ;; segfault for unknown reasons (see:
+                      ;; https://bugreports.qt.io/browse/QTBUG-116018).
+                      "tst_qgraphicsview"
+                      "tst_qopenglwidget"
+
                       ;; The 'test_rcc' test fails on a comparison:
                       ;; <<<<<< actual
                       ;; 0x0,0x0,0x0,0x0,0x0,0x0,0x3,0xe8,
@@ -853,8 +866,7 @@  (define-public qtbase
                              (search-input-file
                               outputs
                               (string-append "lib/qt6/mkspecs/features/" file)))
-                           '("device_config.prf" "moc.prf" "qt_build_config.prf"
-                             "qt_config.prf"))
+                           '("device_config.prf" "moc.prf" "qt_config.prf"))
                     (("\\$\\$\\[QT_HOST_DATA/get\\]") archdata)
                     (("\\$\\$\\[QT_HOST_DATA/src\\]") archdata)))))))))
     (native-inputs
@@ -863,8 +875,15 @@  (define-public qtbase
                 xvfb-run)))
     (inputs
      (modify-inputs (package-inputs qtbase-5)
-       (prepend bash-minimal coreutils-minimal libxcb md4c)
-       (replace "postgresql" postgresql))) ;use latest postgresql
+       (prepend at-spi2-core
+                bash-minimal
+                coreutils-minimal
+                md4c
+                libice
+                libsm
+                libxcb
+                libxext
+                xcb-util-cursor)))
     (native-search-paths
      (list (search-path-specification
             (variable "QMAKEPATH")