diff mbox series

[bug#65280,v2,12/59] gnu: qtdeclarative: Update to 6.5.2.

Message ID 32eb5c356b35241e313cb71e41d16ffae543d07f.1692187578.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Refresh Qt 5 and 6 packages | expand

Commit Message

Maxim Cournoyer Aug. 16, 2023, 12:10 p.m. UTC
* gnu/packages/qt.scm (qtdeclarative): Update to 6.5.2.
[arguments]: Disable a few extra tests in check phase.
[inputs]: Add at-spi2-core, qtimageformats, qtlanguageserver and qtsvg.
---

(no changes since v1)

 gnu/packages/qt.scm | 27 ++++++++++++++++++++++-----
 1 file changed, 22 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d66ecda169..e362ae7a15 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1300,14 +1300,14 @@  (define-public qtdeclarative-5
 (define-public qtdeclarative
   (package
     (name "qtdeclarative")
-    (version "6.3.2")
+    (version "6.5.2")
     ;; TODO: Package 'masm' and unbundle from sources.
     (source (origin
               (method url-fetch)
               (uri (qt-url name version))
               (sha256
                (base32
-                "1hbw63828pp8vm9b46i2pkcbcpr4mq9nblhmpwrw2pflq0fi24xq"))
+                "06c7xfqn2a5s2m8j1bcvx3pyjqg1rgqkjvp49737gb4z9vjiz8gk"))
               (patches (search-patches "qtdeclarative-disable-qmlcache.patch"))))
     (build-system cmake-build-system)
     (arguments
@@ -1405,7 +1405,20 @@  (define-public qtdeclarative
                     ;; waiting for a killed process, which becomes a zombie in
                     ;; the build container (perhaps solved after
                     ;; fixing/applying #30948).
-                    "tst_qqmlpreview") "|")
+                    "tst_qqmlpreview"
+
+                    ;; These tests fail starting with 6.5.2 (see:
+                    ;; https://bugreports.qt.io/browse/QTBUG-116019).  They
+                    ;; appear to fail because of attempting to load QML from
+                    ;; elsewhere than from QML2_IMPORT_PATH.
+                    "cmake_test_common_import_path"
+                    "tst_qqmlcomponent"
+                    "tst_qmllint"
+                    "tst_qmldomitem"
+                    "tst_dom_all"
+                    "tst_qmlls"
+                    "tst_qmllscompletions"
+                    ) "|")
                   ")")))))
           (add-after 'install 'delete-installed-tests
             (lambda _
@@ -1418,9 +1431,13 @@  (define-public qtdeclarative
            qtshadertools
            vulkan-headers))
     (inputs
-     (list libxkbcommon
+     (list at-spi2-core
+           libxkbcommon
            mesa
-           qtbase))
+           qtbase
+           qtimageformats
+           qtlanguageserver
+           qtsvg))
     (home-page (package-home-page qtbase))
     (synopsis "Qt QML module (Quick 2)")
     (description "The Qt QML module provides a framework for developing