diff mbox series

[bug#65280,v2,11/59] gnu: Add qtlanguageserver.

Message ID 75afb6f2d6cfc5602af6d703895596836e83d032.1692187578.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Refresh Qt 5 and 6 packages | expand

Commit Message

Maxim Cournoyer Aug. 16, 2023, 12:10 p.m. UTC
* gnu/packages/qt.scm (qtlanguageserver): New variable.
---

(no changes since v1)

 gnu/packages/qt.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d9ca408721..d66ecda169 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1940,6 +1940,30 @@  (define-public qtwebview
 application without necessarily including a full web browser stack by using
 native APIs where it makes sense.")))
 
+(define-public qtlanguageserver
+  (package
+    (name "qtlanguageserver")
+    (version "6.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (qt-url name version))
+              (sha256
+               (base32
+                "196iicwpqca2ydpca41qs6aqxxq8ycknw6lm2v00h1w3m86frdbk"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'install 'delete-installed-tests
+                          (lambda _
+                            (delete-file-recursively
+                             (string-append #$output "/tests")))))))
+    (inputs (list qtbase))
+    (home-page (package-home-page qtbase))
+    (synopsis "Implementation of the Language Server Protocol for Qt")
+    (description "This package provides an implementation of the Language
+Server Protocol (LSP) for Qt.")
+    (license (package-license qtbase))))
+
 (define-public qtlocation
   (package
     (inherit qtsvg-5)