diff mbox series

[bug#69449,python-team,6/9] gnu: python-werkzeug: Rename variable to python-werkzeug-2.

Message ID b117f7245c6313188479943e2a17e6a1dcb5e7c9.1709112912.git.tanguy@bioneland.org
State New
Headers show
Series gnu: Add python-flask-3. | expand

Commit Message

Tanguy LE CARROUR Feb. 28, 2024, 10:15 a.m. UTC
* gnu/packages/python-web.scm (python-werkzeug): Rename to...
(python-werkzeug-2): ... this. Add new variable defining
default python-werkzeug.

Change-Id: I6b77baf7731303735bcd7ae707fdd68f8b956c99
---
 gnu/packages/python-web.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 88e40959c3..960ad0d879 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -30,7 +30,7 @@ 
 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2019, 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019, 2020, 2024 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
@@ -4971,7 +4971,7 @@  (define-public python-publicsuffix2
 List.  Forked from and using the same API as the publicsuffix package.")
     (license (list license:expat license:mpl2.0))))
 
-(define-public python-werkzeug
+(define-public python-werkzeug-2
   (package
     (name "python-werkzeug")
     (version "2.0.2")
@@ -5008,7 +5008,7 @@  (define-public python-werkzeug
 
 (define-public python-werkzeug-1.0
   (package
-    (inherit python-werkzeug)
+    (inherit python-werkzeug-2)
     (version "1.0.1")
     (source (origin
               (method url-fetch)
@@ -5030,6 +5030,8 @@  (define-public python-werkzeug-1.0
     (native-inputs
      (list python-pytest python-pytest-timeout))))
 
+(define-public python-werkzeug python-werkzeug-2)
+
 (define-public python-bottle
   (package
     (name "python-bottle")