diff mbox series

[bug#69449,python-team,5/9] gnu: Add python-ephemeral-port-reserve.

Message ID 6d1553d1951618972c75ba4951c09966cb476fd0.1709112912.git.tanguy@bioneland.org
State New
Headers show
Series gnu: Add python-flask-3. | expand

Commit Message

Tanguy LE CARROUR Feb. 28, 2024, 10:15 a.m. UTC
* gnu/packages/python-xyz.scm (python-ephemeral-port-reserve): New variable.

Change-Id: I98d153179ac533fad3fa7c12a838bd12bb615a15
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6f3aec7ed..348b3084b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16439,6 +16439,24 @@  (define-public python-epc
 from elisp.")
     (license license:gpl3)))
 
+(define-public python-ephemeral-port-reserve
+  (package
+    (name "python-ephemeral-port-reserve")
+    (version "1.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ephemeral_port_reserve" version))
+       (sha256
+        (base32 "1chl9hil7ggz6l4sfhmp0l2j55qcskbc3pj9360b0309jwndmxxq"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools python-wheel))
+    (home-page "https://github.com/Yelp/ephemeral-port-reserve/")
+    (synopsis "Utility to bind to an ephemeral port")
+    (description
+     "Bind to an ephemeral port, force it into the TIME_WAIT state, and unbind it.")
+    (license license:expat)))  ;; MIT
+
 (define-public python-forex-python
   (package
     (name "python-forex-python")