diff mbox series

[bug#69449,python-team,4/9] gnu: python-blinker: Update to 1.7.0.

Message ID 3c8515a565a2c610972746757cbb7d1529ff0414.1709112912.git.tanguy@bioneland.org
State New
Headers show
Series gnu: Add python-flask-3. | expand

Commit Message

Tanguy LE CARROUR Feb. 28, 2024, 10:15 a.m. UTC
* gnu/packages/python-xyz.scm (python-blinker): Update to 1.7.0.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add python-flit-core, python-pytest and
python-pytest-asyncio.

Change-Id: Ie825fb38b326facf54b0788c78733b8de4a74920
---
 gnu/packages/python-xyz.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c7492650cc..a6f3aec7ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7654,16 +7654,17 @@  (define-public python-black-macchiato
 (define-public python-blinker
   (package
     (name "python-blinker")
-    (version "1.4")
+    (version "1.7.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "blinker" version))
        (sha256
         (base32
-         "1dpq0vb01p36jjwbhhd08ylvrnyvcc82yxx3mwjx6awrycjyw6j7"))))
-    (build-system python-build-system)
-    (home-page "https://pythonhosted.org/blinker/")
+         "10k1k4raxkfdan2vj4p1zvj4gxf394vjihj74y71skafzbv0z0p6"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-flit-core python-pytest python-pytest-asyncio))
+    (home-page "https://blinker.readthedocs.io")
     (synopsis "Fast, simple object-to-object and broadcast signaling")
     (description
      "Blinker provides a fast dispatching system that allows any number of