diff mbox series

[bug#69449,python-team,9/9] gnu: Add python-flask-3.

Message ID 03a03ed64a62e23b9d3da8758dbf7754b186982f.1709112912.git.tanguy@bioneland.org
State New
Headers show
Series gnu: Add python-flask-3. | expand

Commit Message

Tanguy LE CARROUR Feb. 28, 2024, 10:15 a.m. UTC
* gnu/packages/python-web.scm (python-flask-3): New variable.

Change-Id: I8556a3e2fed74368c6d4db99cd859ecb33a3d573
---
 gnu/packages/python-web.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3bdabc311a..215cdd2335 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3957,6 +3957,39 @@  (define-public python-flask-2
 presume or force a developer to use a particular tool or library.")
     (license license:bsd-3)))
 
+(define-public python-flask-3
+  (package
+    (name "python-flask")
+    (version "3.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "flask" version))
+              (sha256
+               (base32
+                "0zfbxxgl5zpbvswxywrr6fam6rj0vknv317flx84484rnzs06b42"))))
+    (build-system pyproject-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "pytest" "-vv" "tests")))))))
+    (native-inputs
+     (list python-flit-core python-pytest))
+    (propagated-inputs
+     (list python-blinker
+           python-click
+           python-itsdangerous
+           python-jinja2
+           python-werkzeug-3))
+    (home-page "https://flask.palletsprojects.com")
+    (synopsis "Microframework based on Werkzeug, Jinja2 and good intentions")
+    (description "Flask is a micro web framework based on the Werkzeug toolkit
+and Jinja2 template engine.  It is called a micro framework because it does not
+presume or force a developer to use a particular tool or library.")
+    (license license:bsd-3)))
+
 (define-public python-flask python-flask-2)
 
 (define-public python-flask-compress