diff mbox series

[bug#69449,python-team,7/9] gnu: Add python-werkzeug-3.

Message ID a61664ebf35236552ac68ea81b57acfa57835b2c.1709112912.git.tanguy@bioneland.org
State New
Headers show
Series gnu: Add python-flask-3. | expand

Commit Message

Tanguy LE CARROUR Feb. 28, 2024, 10:15 a.m. UTC
* gnu/packages/python-web.scm (python-werkzeug-3): New variable.

Change-Id: I9e53b3a5e303cc36aeaf7b3cfb678fb6aab1b6a7
---
 gnu/packages/python-web.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 960ad0d879..e8edc1604c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5030,6 +5030,41 @@  (define-public python-werkzeug-1.0
     (native-inputs
      (list python-pytest python-pytest-timeout))))
 
+(define-public python-werkzeug-3
+  (package
+    (name "python-werkzeug")
+    (version "3.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "werkzeug" version))
+       (sha256
+        (base32 "1k0x7fxlbvshcpbr9d16z2w1s3irngadwyll0jj1hax7rqg82zjh"))))
+    (build-system pyproject-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+                      (when tests?
+                        ;; Some tests rely on the network and on a newer version
+                        ;; or python-watchdog.
+                        (delete-file "tests/test_serving.py")
+                        (invoke "python" "-m" "pytest")))))))
+    (propagated-inputs (list))
+    (native-inputs (list python-ephemeral-port-reserve python-flit-core
+                         python-markupsafe python-watchdog
+                         python-pytest python-pytest-timeout
+                         python-pytest-xprocess))
+    (home-page "https://werkzeug.palletsprojects.com")
+    (synopsis "Utilities for WSGI applications")
+    (description
+     "One of the most advanced WSGI utility modules.  It includes a
+powerful debugger, full-featured request and response objects, HTTP utilities to
+handle entity tags, cache control headers, HTTP dates, cookie handling, file
+uploads, a powerful URL routing system and a bunch of community-contributed
+addon modules.")
+    (license license:bsd-3)))
+
 (define-public python-werkzeug python-werkzeug-2)
 
 (define-public python-bottle