diff mbox series

[bug#44562,06/15] gnu: Add go-github-com-goccy-yaml.

Message ID 87o8k496be.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#44562,01/15] gnu: Add go-github-com-leodido-go-urn. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Nov. 10, 2020, 10:48 p.m. UTC
--
Joseph LaFreniere
diff mbox series

Patch

From 922de851d989ec1ae910fd507d3de4e89969bd2c Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 26 Jul 2020 23:55:03 -0500
Subject: [PATCH 06/15] gnu: Add go-github-com-goccy-yaml.

* gnu/packages/golang.scm (go-github-com-goccy-yaml): New variable.
---
 gnu/packages/golang.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 32605fbc65..a902f7cd5c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6203,3 +6203,44 @@  JSON data to the machine.")
 systems can import this package to enable running programs as services without
 modifying them.")
     (license license:zlib)))
+
+(define-public go-github-com-goccy-yaml
+  (package
+    (name "go-github-com-goccy-yaml")
+    (version "1.8.0")
+    (home-page "https://github.com/goccy/go-yaml")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1nps58dwkd915mx35h5f0dc05b880b4fdl6dcjxpfmmbzyinvg38"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/goccy/go-yaml"))
+    (inputs
+     `(("go-github-com-fatih-color" ,go-github-com-fatih-color)
+       ("go-github-com-go-playground-locales"
+        ,go-github-com-go-playground-locales)
+       ("go-github-com-go-playground-universal-translator"
+        ,go-github-com-go-playground-universal-translator)
+       ("go-github-com-leodido-go-urn" ,go-github-com-leodido-go-urn)
+       ("go-golang-org-x-xerrors" ,go-golang-org-x-xerrors)
+       ("go-gopkg-in-go-playground-validator-v9"
+        ,go-gopkg-in-go-playground-validator-v9)))
+    (synopsis "YAML support for the Go language")
+    (description
+     "This package provides features beyond the
+@uref{https://github.com/go-yaml/yaml, defacto YAML library} including:
+
+@itemize
+@item Pretty format for error notifications
+@item Support Scanner or Lexer or Parser as public API
+@item Support Anchor and Alias to Marshaler
+@item Allow referencing elements declared in another file via anchors
+@item Extract value or AST by YAMLPath (YAMLPath is like a JSONPath)
+@end itemize")
+    (license license:expat)))
-- 
2.29.2