diff mbox series

[bug#44562,10/15] gnu: Add go-github-com-daviddengcn-go-colortext.

Message ID 87d00k967z.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#44562,01/15] gnu: Add go-github-com-leodido-go-urn. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Nov. 10, 2020, 10:50 p.m. UTC
--
Joseph LaFreniere
diff mbox series

Patch

From e37a23dae6340f162d474dde9b929b25d53f518f Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 8 Nov 2020 21:36:52 -0600
Subject: [PATCH 10/15] gnu: Add go-github-com-daviddengcn-go-colortext.

* gnu/packages/golang.scm (go-github-com-daviddengcn-go-colortext): New variable.
---
 gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index aa4edc85ec..b903077ed4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -500,6 +500,33 @@  jar struct to manage the cookies added to the cookie jar.")
     (description "This package provides additions to Go's stdlib @code{fmt}.")
     (license license:bsd-3)))
 
+(define-public go-github-com-daviddengcn-go-colortext
+  (package
+    (name "go-github-com-daviddengcn-go-colortext")
+    (version "1.0.0")
+    (home-page "https://github.com/daviddengcn/go-colortext")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0j5ldwg3a768d3nniiglghr9axj4p87k7f7asqxa1a688xvcms48"))))
+    (build-system go-build-system)
+    (native-inputs
+     `(("go-github-com-golangplus-testing" ,go-github-com-golangplus-testing)))
+    (arguments
+     '(#:import-path "github.com/daviddengcn/go-colortext"))
+    (synopsis "Change the color of console text and background")
+    (description
+     "This is a package to change the color of the text and background in the
+console, working both under Windows and other systems.
+
+Under Windows, the console APIs are used. Otherwise, ANSI texts are output.")
+    ;; dual-licensed
+    (license (list license:bsd-3 license:expat))))
+
 (define-public go-github-com-golangplus-testing
   (package
     (name "go-github-com-golangplus-testing")
-- 
2.29.2