diff mbox series

[bug#44562,01/15] gnu: Add go-github-com-leodido-go-urn.

Message ID 87361galdn.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#44562,01/15] gnu: Add go-github-com-leodido-go-urn. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Nov. 10, 2020, 10:37 p.m. UTC
This is building toward github.com/x-motemen/ghq.  I'm not a Go 
developer and didn't find golang.scm to be entirely consistent in 
its conventions, so I'm anticipating some cleanup of these patches 
will be required.

--
Joseph LaFreniere

Comments

Efraim Flashner Jan. 3, 2021, 3:23 p.m. UTC | #1
On Tue, Nov 10, 2020 at 04:37:56PM -0600, Joseph LaFreniere wrote:
> This is building toward github.com/x-motemen/ghq.  I'm not a Go developer
> and didn't find golang.scm to be entirely consistent in its conventions, so
> I'm anticipating some cleanup of these patches will be required.
> 
> --
> Joseph LaFreniere

> From a806f9922aaccacb30c920bacde94edcc9a630af Mon Sep 17 00:00:00 2001
> From: Joseph LaFreniere <joseph@lafreniere.xyz>
> Date: Sun, 26 Jul 2020 17:34:08 -0500
> Subject: [PATCH 01/15] gnu: Add go-github-com-leodido-go-urn.
> 
> * gnu/packages/golang.scm (go-github-com-leodido-go-urn): New variable.
> ---
>  gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
> 
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 82573bd099..43f9a5ed74 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -480,6 +480,31 @@ jar struct to manage the cookies added to the cookie jar.")
>        (home-page "https://github.com/aki237/nscjar")
>        (license license:expat))))
>  
> +(define-public go-github-com-leodido-go-urn
> +  (package
> +    (name "go-github-com-leodido-go-urn")
> +    (version "1.2.0")
> +    (home-page "https://github.com/leodido/go-urn")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url home-page)
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1d4g1vkhc1180l1n7q48vl84b27c7cziywml78cyijbcdz2f8vim"))))
> +    (build-system go-build-system)
> +    (arguments
> +     '(#:import-path "github.com/leodido/go-urn"))
> +    (inputs
> +     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))

This one was needed only for the tests so I moved it to native-inputs

> +    (synopsis "Parser for uniform resource names as seen on RFC 2141")
> +    (description
> +     "This package implements a parser for uniform resource names (URN) as
> +specified by @uref{https://tools.ietf.org/html/rfc2141, IETF RFC 2141}.")
> +    (license license:expat)))
> +
>  (define-public go-github.com-jessevdk-go-flags
>    (package
>      (name "go-github.com-jessevdk-go-flags")
> -- 
> 2.29.2
>
diff mbox series

Patch

From a806f9922aaccacb30c920bacde94edcc9a630af Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 26 Jul 2020 17:34:08 -0500
Subject: [PATCH 01/15] gnu: Add go-github-com-leodido-go-urn.

* gnu/packages/golang.scm (go-github-com-leodido-go-urn): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 82573bd099..43f9a5ed74 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -480,6 +480,31 @@  jar struct to manage the cookies added to the cookie jar.")
       (home-page "https://github.com/aki237/nscjar")
       (license license:expat))))
 
+(define-public go-github-com-leodido-go-urn
+  (package
+    (name "go-github-com-leodido-go-urn")
+    (version "1.2.0")
+    (home-page "https://github.com/leodido/go-urn")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1d4g1vkhc1180l1n7q48vl84b27c7cziywml78cyijbcdz2f8vim"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/leodido/go-urn"))
+    (inputs
+     `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))
+    (synopsis "Parser for uniform resource names as seen on RFC 2141")
+    (description
+     "This package implements a parser for uniform resource names (URN) as
+specified by @uref{https://tools.ietf.org/html/rfc2141, IETF RFC 2141}.")
+    (license license:expat)))
+
 (define-public go-github.com-jessevdk-go-flags
   (package
     (name "go-github.com-jessevdk-go-flags")
-- 
2.29.2