diff mbox series

[bug#44562,14/15] gnu: Add go-github-com-x-motemen-ghq.

Message ID 871rh0962e.fsf@lafreniere.xyz
State Accepted
Headers show
Series [bug#44562,01/15] gnu: Add go-github-com-leodido-go-urn. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Nov. 10, 2020, 10:54 p.m. UTC
--
Joseph LaFreniere
diff mbox series

Patch

From 77389b438ddacdfec2b8c46182297b7bd9326be8 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 8 Nov 2020 13:11:51 -0600
Subject: [PATCH 14/15] gnu: Add go-github-com-x-motemen-ghq.

* gnu/packages/golang.scm (go-github-com-x-motemen-ghq): New variable.
---
 gnu/packages/golang.scm | 45 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4e741f4504..8a45e64efa 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -58,6 +58,7 @@ 
   #:use-module (gnu packages mp3)
   #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages version-control)
   #:use-module (gnu packages web)
   #:use-module (ice-9 match)
   #:use-module (srfi srfi-1))
@@ -6407,3 +6408,47 @@  modifying them.")
        "This package provides an HTML5-compliant tokenizer and parser.")
       (home-page "https://godoc.org/golang.org/x/net/html")
       (license license:bsd-3))))
+
+(define-public go-github-com-x-motemen-ghq
+  (package
+    (name "go-github-com-x-motemen-ghq")
+    (version "1.1.5")
+    (home-page "https://github.com/x-motemen/ghq")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "098fik155viylq07az7crzbgswcvhpx0hr68xpvyx0rpri792jbq"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/x-motemen/ghq"))
+    (native-inputs
+     `(("github.com/go/md2man" ,go-github-com-go-md2man)))
+    (inputs
+     `(("github.com/Songmu/gitconfig" ,go-github-com-Songmu-gitconfig)
+       ("github.com/daviddengcn/go-colortext" ,go-github-com-daviddengcn-go-colortext)
+       ("github.com/fatih/color" ,go-github-com-fatih-color)
+       ("github.com/goccy/yaml" ,go-github-com-goccy-yaml)
+       ("github.com/mattn/go-isatty" ,go-github-com-mattn-go-isatty)
+       ("github.com/motemen/go-colorine" ,go-github-com-motemen-go-colorine)
+       ("github.com/saracen/walker" ,go-github-com-saracen-walker)
+       ("github.com/urfave/cli/v2" ,go-github-com-urfave-cli-v2)
+       ("golang.org/x/net/html" ,go-golang.org-x-net-html)
+       ("golang.org/x/sync/errgroup" ,go-golang.org-x-sync-errgroup)
+       ("golang.org/x/xerrors" ,go-golang-org-x-xerrors)
+       ("gopkg.in/yaml.v2" ,go-gopkg-in-yaml-v2)
+       ("perl" ,perl)))
+    (propagated-inputs
+     `(("fossil" ,fossil)
+       ("git" ,git-minimal)))
+    (synopsis "Manage remote repository clones")
+    (description
+     "code{ghq} provides a way to organize remote repository clones, like
+@code{go get} does.  When you clone a remote repository by @code{ghq get}, ghq
+makes a directory under a specific root directory (by default @file{~/ghq})
+using the remote repository URL's host and path.")
+    (license license:expat)))
-- 
2.29.2