diff mbox series

[bug#49729,core-updates,03/20] gnu: khmer: Remove obsolete phase.

Message ID 4653284d9fd1c732063872170fb197af734b2f2f.1627351168.git.iskarian@mgsn.dev
State New
Headers show
Series Remove obsolete phases making gzip files writable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen July 27, 2021, 2:56 a.m. UTC
* gnu/packages/bioinformatics.scm (khmer)[arguments]<#:phases>: Remove
'make-files-writable phase.
---
 gnu/packages/bioinformatics.scm | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f027da3ce7..76a8160aa6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4739,16 +4739,7 @@  command, or queried for specific k-mers with @code{jellyfish query}.")
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'set-cc
-           (lambda _ (setenv "CC" "gcc") #t))
-
-         (add-before 'reset-gzip-timestamps 'make-files-writable
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; Make sure .gz files are writable so that the
-             ;; 'reset-gzip-timestamps' phase can do its work.
-             (let ((out (assoc-ref outputs "out")))
-               (for-each make-file-writable
-                         (find-files out "\\.gz$"))
-               #t))))))
+           (lambda _ (setenv "CC" "gcc") #t)))))
     (native-inputs
      `(("python-cython" ,python-cython)
        ("python-pytest" ,python-pytest)