diff mbox series

[bug#49729,core-updates,20/20] gnu: cpuid: Remove obsolete file permissions change.

Message ID 7ea269be17494a5b957cf20050dd7e8580d6a9fb.1627351168.git.iskarian@mgsn.dev
State New
Headers show
Series Remove obsolete phases making gzip files writable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen July 27, 2021, 7:26 p.m. UTC
* gnu/packages/linux.scm (cpuid)[arguments]<#:phases>{fix-makefile}:
Remove Makefile gzip permissions patch.
---
 gnu/packages/linux.scm | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9e3ad367e2..d8787c9154 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7073,12 +7073,7 @@  available in the kernel Linux.")
                   (add-before 'install 'fix-makefile
                     (lambda* (#:key outputs #:allow-other-keys)
                       (substitute* "Makefile"
-                        (("\\$\\(BUILDROOT\\)/usr") (assoc-ref outputs "out")))
-                      ;; Make the compressed manpages writable so that the
-                      ;; reset-gzip-timestamps phase does not error out.
-                      (substitute* "Makefile"
-                        (("-m 444") "-m 644"))
-                      #t)))))
+                        (("\\$\\(BUILDROOT\\)/usr") (assoc-ref outputs "out"))))))))
     (inputs `(("perl" ,perl)))
     (supported-systems '("i686-linux" "x86_64-linux"))
     (home-page "http://www.etallen.com/cpuid.html")