diff mbox series

[bug#49729,core-updates,09/20] gnu: go-github-com-gdamore-tcell: Remove obsolete phase.

Message ID 4d8029049c070d3762fecf430334ba7eb1efa26d.1627351168.git.iskarian@mgsn.dev
State New
Headers show
Series Remove obsolete phases making gzip files writable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen July 27, 2021, 2:56 a.m. UTC
* gnu/packages/golang.scm (go-github-com-gdamore-tcell)[arguments]
<#:phases>: Remove 'make-files-writable phase.
---
 gnu/packages/golang.scm | 12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e2b557f5ee..232c2fef38 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5211,17 +5211,7 @@  non-UTF-friendly sources.")
            "0il2nnxp2cqiy73m49215dnf9in3vd25ji8qxbmq87c5qy7i1q9d"))))
       (build-system go-build-system)
       (arguments
-       `(#:import-path "github.com/gdamore/tcell"
-         #:phases
-         (modify-phases %standard-phases
-           (add-before 'reset-gzip-timestamps 'make-files-writable
-             (lambda* (#:key outputs #:allow-other-keys)
-               ;; Make sure .gz files are writable so that the
-               ;; 'reset-gzip-timestamps' phase can do its work.
-               (let ((out (assoc-ref outputs "out")))
-                 (for-each make-file-writable
-                           (find-files out "\\.gz$"))
-                 #t))))))
+       `(#:import-path "github.com/gdamore/tcell"))
       (inputs
        `(("go-github.com-mattn-go-runewidth" ,go-github.com-mattn-go-runewidth)
          ("go-golang-org-colorful" ,go-golang-org-colorful)