diff mbox series

[bug#49729,core-updates,17/20] gnu: python-pdfminer-six: Remove obsolete phase.

Message ID d6c94d3d3d85ec50898f3d269eceea77368e07a2.1627351168.git.iskarian@mgsn.dev
State New
Headers show
Series Remove obsolete phases making gzip files writable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen July 27, 2021, 2:56 a.m. UTC
* gnu/packages/python-xyz.scm (python-pdfminer-six)[arguments]
<#:phases>: Remove 'make-files-writable phase.
---
 gnu/packages/python-xyz.scm | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 60a0ea5f5d..5e99a892d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13597,13 +13597,7 @@  module, adding support for Unicode strings.")
              #t))
          (replace 'check
            (lambda _
-             (invoke "make" "test")))
-         (add-before 'reset-gzip-timestamps 'make-files-writable
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out")))
-               (for-each make-file-writable
-                         (find-files out "\\.gz$"))
-               #t))))))
+             (invoke "make" "test"))))))
     (propagated-inputs
      `(("python-chardet" ,python-chardet)
        ("python-cryptography" ,python-cryptography)