diff mbox series

[bug#49729,core-updates,18/20] gnu: go-github-com-prometheus-common: Remove obsolete phase.

Message ID 1aba445c679e00c1d048ecac66be4e2313c8f0dc.1627351168.git.iskarian@mgsn.dev
State New
Headers show
Series Remove obsolete phases making gzip files writable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen July 27, 2021, 2:56 a.m. UTC
* gnu/packages/syncthing.scm (go-github-com-prometheus-common)
[arguments]<#:phases>: Remove 'make-gzip-archive-writable phase.
---
 gnu/packages/syncthing.scm | 9 ---------
 1 file changed, 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 5cb8449e44..bc3640be8e 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -894,15 +894,6 @@  message streaming.")
          #:tests? #f
          #:phases
          (modify-phases %standard-phases
-           (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
-             (lambda* (#:key outputs #:allow-other-keys)
-               (map (lambda (file)
-                      (make-file-writable file))
-                    (find-files
-                      (string-append (assoc-ref outputs "out")
-                                     "/src/github.com/prometheus/common/expfmt/testdata/")
-                      ".*\\.gz$"))
-               #t))
            ;; Source-only package
            (delete 'build))))
       (propagated-inputs