diff mbox series

[bug#65096,07/10] gnu: ceres: Propagate eigen and gflags.

Message ID 20230805133123.1128243-7-monego@posteo.net
State New
Headers show
Series And OpenTURNS and some math libraries. | expand

Commit Message

Vinicius Monego Aug. 5, 2023, 1:31 p.m. UTC
* gnu/packages/maths.scm (ceres)[inputs]: Move eigen and gflags to ...
[propagated-inputs]: ... here.
---
 gnu/packages/maths.scm | 14 ++++----------
 1 file changed, 4 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7accf87baf..9e283ca889 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2864,16 +2864,10 @@  (define-public ceres
                       (substitute* "CMakeLists.txt"
                         (("set\\(LIB_SUFFIX \"64\"\\)")
                          "set(LIB_SUFFIX \"\")")))))))
-    (native-inputs
-     (list pkg-config))
-    (propagated-inputs
-     (list glog))                           ;for #include <glog/glog.h>
-    (inputs
-     (list eigen
-           openblas
-           lapack
-           suitesparse
-           gflags))
+    (native-inputs (list pkg-config))
+    ;; These inputs need to be propagated to satisfy dependent packages.
+    (propagated-inputs (list eigen gflags glog))
+    (inputs (list openblas lapack suitesparse))
     (synopsis "C++ library for solving large optimization problems")
     (description
      "Ceres Solver is a C++ library for modeling and solving large,