diff mbox series

[bug#65096,08/10] gnu: Add python-numpoly.

Message ID 20230805133123.1128243-8-monego@posteo.net
State New
Headers show
Series And OpenTURNS and some math libraries. | expand

Commit Message

Vinicius Monego Aug. 5, 2023, 1:31 p.m. UTC
* gnu/packages/python-science.scm (python-numpoly): New variable.
---
 gnu/packages/python-science.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 86ba4209fd..9ed3359542 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -630,6 +630,28 @@  (define-public python-bottleneck
 written in C.")
     (license license:bsd-2)))
 
+(define-public python-numpoly
+  (package
+    (name "python-numpoly")
+    (version "1.2.11")
+    (source (origin
+              (method git-fetch) ;; PyPI is missing some Pytest fixtures
+              (uri (git-reference
+                    (url "https://github.com/jonathf/numpoly")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01g21v91f4d66xd0bvap0n6d6485w2fnq1636gx6h2s42550rlbd"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-importlib-metadata python-numpy))
+    (native-inputs (list python-pytest python-sympy))
+    (home-page "https://numpoly.readthedocs.io/en/master/")
+    (synopsis "Polynomials as a numpy datatype")
+    (description "Numpoly is a generic library for creating, manipulating and
+evaluating arrays of polynomials based on @code{numpy.ndarray objects}.")
+    (license license:bsd-2)))
+
 (define-public python-baycomp
   (package
     (name "python-baycomp")