diff mbox series

[bug#65096,01/10] gnu: Add hmat.

Message ID 20230805133123.1128243-1-monego@posteo.net
State New
Headers show
Series And OpenTURNS and some math libraries. | expand

Commit Message

Vinicius Monego Aug. 5, 2023, 1:31 p.m. UTC
* gnu/packages/maths.scm (hmat): New variable.
---
 gnu/packages/maths.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0d74a2a55c..7784268453 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1293,6 +1293,30 @@  (define-public gnuplot
     (license (license:fsf-free
               "http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright"))))
 
+(define-public hmat
+  (package
+    (name "hmat")
+    (version "1.8.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/jeromerobert/hmat-oss")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vxrly6qcnry73p9297jkkixs1rrzy4wh6y35p7jy1dnx90m599p"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; Examples are the tests.
+     (list #:configure-flags #~(list "-DBUILD_EXAMPLES=ON")))
+    (inputs (list openblas))
+    (home-page "https://github.com/jeromerobert/hmat-oss")
+    (synopsis "Hierarchical matrix library")
+    (description "@code{hmat-oss} is hierarchical matrix library written in
+C++ with a C API.  It contains a LU and LLt solver, and a few other things.")
+    (license license:gpl2+)))
+
 (define-public gctp
   (package
     (name "gctp")