mbox series

[bug#65096,00/10] And OpenTURNS and some math libraries.

Message ID 20230805132819.1127742-1-monego@posteo.net
Headers show
Series And OpenTURNS and some math libraries. | expand

Message

Vinicius Monego Aug. 5, 2023, 1:28 p.m. UTC
Hi Guix,

OpenTURNS is a library of numerical tools for uncertainty quantification. I had to skip some of its tests (see test notes in the package).

Vinicius Monego (10):
  gnu: Add hmat.
  gnu: Add primesieve.
  gnu: Add cminpack.
  gnu: Add bonmin.
  gnu: Add pagmo2.
  gnu: Add spectra.
  gnu: ceres: Propagate eigen and gflags.
  gnu: Add python-numpoly.
  gnu: Add python-chaospy.
  gnu: Add python-openturns.

 gnu/packages/algebra.scm        |  34 ++++++++
 gnu/packages/maths.scm          | 141 +++++++++++++++++++++++++++++---
 gnu/packages/python-science.scm |  22 +++++
 gnu/packages/statistics.scm     | 119 +++++++++++++++++++++++++++
 4 files changed, 306 insertions(+), 10 deletions(-)

Comments

Maxim Cournoyer Sept. 5, 2023, 2:25 p.m. UTC | #1
tags 65096 + moreinfo
quit

Hi,

Vinicius Monego <monego@posteo.net> writes:

> Hi Guix,
>
> OpenTURNS is a library of numerical tools for uncertainty quantification. I had to skip some of its tests (see test notes in the package).
>
> Vinicius Monego (10):
>   gnu: Add hmat.
>   gnu: Add primesieve.
>   gnu: Add cminpack.
>   gnu: Add bonmin.
>   gnu: Add pagmo2.
>   gnu: Add spectra.
>   gnu: ceres: Propagate eigen and gflags.
>   gnu: Add python-numpoly.
>   gnu: Add python-chaospy.
>   gnu: Add python-openturns.

There were some failures on non x86_64 systems, according to QA [0].
Could you take a look and see if something can be fixed (sometimes
patches can be taken from Debian or somewhere else, or an issue exists
upstream, etc.)

[0]  https://qa.guix.gnu.org/issue/65096
Vinicius Monego Sept. 23, 2023, 11:11 p.m. UTC | #2
Em 05/09/2023 11:25, Maxim Cournoyer escreveu:
> tags 65096 + moreinfo
> quit
>
> Hi,

Hi,

[...]

> There were some failures on non x86_64 systems, according to QA [0].
> Could you take a look and see if something can be fixed (sometimes
> patches can be taken from Debian or somewhere else, or an issue exists
> upstream, etc.)
>
> [0]  https://qa.guix.gnu.org/issue/65096
>
The failing packges are cminpack (on aarch64) and pagmo and 
python-numpoly (on 32-bit platforms).

cminpack builds on Debian arm64 (same as aarch64 on Guix) without 
special patches, so I don't know why the tests are failing in aarch64. 
They have a "skip failing tests" patch but it's skipping tests different 
from the ones failing here. The Debian package is based on a slightly 
older version (1.3.6 vs 1.3.8), though. It may have something to do with 
this issue: 
https://github.com/devernay/cminpack/issues/37#issuecomment-1407259802

pagmo only supports 64-bit x86, ARM and PowerPC: 
https://esa.github.io/pagmo2/install.html

python-numpoly is only available in Fedora and Alpine for 64-bit 
architectures. The test errors in the build logs are also dtype 
mismatches between int64 and int32.

My suggestion is to add supported-systems in pagmo and python-numpoly, 
and push cminpack as is (or maybe skip tests on aarch64 and powerpc64le?)

Vinicius
Vinicius Monego Oct. 3, 2023, 11:01 a.m. UTC | #3
Pushed as 9f41aa021f982b3fc23927e2988c59329acdc8fc after adding 
supported-systems to pagmo and numpoly. Closing now, thanks for the 
comments.