diff mbox series

[bug#64896,7/8] gnu: Add python-milc.

Message ID 20230727125741.8766-7-jean@foundationdevices.com
State New
Headers show
Series [bug#64896,1/8] gnu: Add python-hid. | expand

Commit Message

Jean-Pierre De Jesus DIAZ July 27, 2023, 12:57 p.m. UTC
* gnu/packages/python-xyz.scm (python-milc): New variable.

Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6d789aacf..72f1936732 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4234,6 +4234,26 @@  (define-public python-extras
      "Extras is a set of extensions to the Python standard library.")
     (license license:expat)))
 
+(define-public python-milc
+  (package
+    (name "python-milc")
+    (version "1.6.8")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "milc" version))
+              (sha256
+               (base32
+                "1pnwdg2653lc82qsv6c0kv9qcydh2f6w5mx5l4227zy1f6kr7b52"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-appdirs python-argcomplete python-colorama
+                             python-halo python-spinners))
+    (home-page "https://github.com/clueboard/milc")
+    (synopsis "Python library for command line interface programs")
+    (description "MILC is a Python library for developing command line
+interface programs.  This library provides features to parse arguments,
+automatic tab-completion, color support, logging to @code{std}, etc.")
+    (license license:expat)))
+
 (define-public python-mimeparse
   (package
     (name "python-mimeparse")