diff mbox series

[bug#64896,3/8] gnu: Add python-log-symbols.

Message ID 20230727125741.8766-3-jean@foundationdevices.com
State New
Headers show
Series [bug#64896,1/8] gnu: Add python-hid. | expand

Commit Message

Jean-Pierre De Jesus DIAZ July 27, 2023, 12:57 p.m. UTC
* gnu/packages/terminals.scm (python-log-symbols): New variable.

Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
---
 gnu/packages/terminals.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 8f7e3c0e9a..bfb333aba9 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1178,6 +1178,34 @@  (define-public python-curtsies
 per-line fullscreen terminal rendering, and keyboard input event reporting.")
     (license license:expat)))
 
+(define-public python-log-symbols
+  (package
+    (name "python-log-symbols")
+    (version "0.0.14")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "log_symbols" version))
+              (sha256
+               (base32
+                "0mh5d0igw33libfmbsr1ri1p1y644p36nwaa2w6kzrd8w5pvq2yg"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'relax-requirements
+                 (lambda _
+                   (substitute* "requirements-dev.txt"
+                     (("(.*)==(.*)$" _ dep ver)
+                      (string-append dep ">=" ver))))))))
+    (propagated-inputs (list python-colorama))
+    (native-inputs (list python-coverage python-nose python-pylint python-tox))
+    (home-page "https://github.com/manrajgrover/py-log-symbols")
+    (synopsis "Python library with graphical symbols for logging on the terminal")
+    (description "This package provides a Python library with graphical symbols
+that can be displayed on the terminal, with color if possible, for logging
+purposes.")
+    (license license:expat)))
+
 (define-public python-spinners
   (package
     (name "python-spinners")