diff mbox series

[bug#64896,5/8] gnu: Add python-hjson.

Message ID 20230727125741.8766-5-jean@foundationdevices.com
State New
Headers show
Series [bug#64896,1/8] gnu: Add python-hid. | expand

Commit Message

Jean-Pierre De Jesus DIAZ July 27, 2023, 12:57 p.m. UTC
* gnu/packages/python-xyz.scm (python-hjson): New variable.

Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index db3e69fb45..91dbbe7d83 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -139,6 +139,7 @@ 
 ;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
 ;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
 ;;; Copyright © 2023 Ontje Lünsdorf <ontje.luensdorf@dlr.de>
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2166,6 +2167,30 @@  (define-public python-h5py
 concepts.")
     (license license:bsd-3)))
 
+(define-public python-hjson
+  ;; Using commit from master branch as the PyPI version does not contain
+  ;; the hjson/tests/ directory.
+  (let ((revision "0")
+        (commit "1687b811fcbbc54b5ac71cfbaa99f805e406fbcb"))
+    (package
+      (name "python-hjson")
+      (version (git-version "3.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/hjson/hjson-py")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1qfqnhvfx5mm7bdajjnnagmvns1zxyksjzh3k5la2ag6a8bp5gki"))))
+      (build-system pyproject-build-system)
+      (home-page "http://github.com/hjson/hjson-py")
+      (synopsis "Python package to parse HJSON documents")
+      (description "This package provides a Python library and a command-line
+interface utility to parse @url{https://hjson.github.io/, HJSON}) documents.")
+      (license license:expat))))
+
 (define-public python-hnswlib
   (package
     (name "python-hnswlib")