diff mbox series

[bug#64896,6/8] gnu: Add python-dotty-dict.

Message ID 20230727125741.8766-6-jean@foundationdevices.com
State New
Headers show
Series [bug#64896,1/8] gnu: Add python-hid. | expand

Commit Message

Jean-Pierre De Jesus DIAZ July 27, 2023, 12:57 p.m. UTC
* gnu/packages/python-xyz.scm (python-dotty-dict): New variable.

Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 91dbbe7d83..a6d789aacf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -625,6 +625,25 @@  (define-public python-dotmap
 dictionary, can be convert to a dictionary, and is ordered by insertion.")
     (license license:expat)))
 
+(define-public python-dotty-dict
+  (package
+    (name "python-dotty-dict")
+    (version "1.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "dotty_dict" version))
+              (sha256
+               (base32
+                "058sah2nyg44xq5wxywlzc3abzcv9fifnlvsflwma9mfp01nw0ab"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-poetry-core))
+    (home-page "https://github.com/pawelzny/dotty_dict")
+    (synopsis "Python library for accessing dictionaries using a dot syntax")
+    (description "This package provides a library that wraps the traditional
+Python dictionaries and provides a syntax to access nested dictionaries values
+using a dot syntax, for example: @code{dictionary['deeply.nested.key']}.")
+    (license license:expat)))
+
 (define-public python-twodict
   (package
     (name "python-twodict")