diff mbox series

[bug#64896,4/8] gnu: Add python-halo.

Message ID 20230727125741.8766-4-jean@foundationdevices.com
State New
Headers show
Series [bug#64896,1/8] gnu: Add python-hid. | expand

Commit Message

Jean-Pierre De Jesus DIAZ July 27, 2023, 12:57 p.m. UTC
* gnu/packages/terminals.scm (python-halo): New variable.

Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com>
---
 gnu/packages/terminals.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index bfb333aba9..8df3fedfd6 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1178,6 +1178,27 @@  (define-public python-curtsies
 per-line fullscreen terminal rendering, and keyboard input event reporting.")
     (license license:expat)))
 
+(define-public python-halo
+  (package
+    (name "python-halo")
+    (version "0.0.31")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "halo" version))
+              (sha256
+               (base32
+                "1mn97h370ggbc9vi6x8r6akd5q8i512y6kid2nvm67g93r9a6rvv"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-colorama python-log-symbols python-six
+                             python-spinners python-termcolor))
+    (native-inputs (list python-coverage python-nose python-pylint python-tox
+                         python-twine))
+    (home-page "https://github.com/manrajgrover/halo")
+    (synopsis "Python library to display graphical spinners in the terminal.")
+    (description "Halo is a Python library to display graphical spinners in
+the terminal.  It also supports IPython/Jupyter.")
+    (license license:expat)))
+
 (define-public python-log-symbols
   (package
     (name "python-log-symbols")