diff mbox series

[bug#63621,4/6] gnu: Add python-botorch.

Message ID 20230521030210.1282819-4-monego@posteo.net
State New
Headers show
Series Add PyTorch-related statistics libraries. | expand

Commit Message

Vinicius Monego May 21, 2023, 3:02 a.m. UTC
* gnu/packages/machine-learning.scm (python-botorch): New variable.
---
 gnu/packages/machine-learning.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 90bfe283a2..1e34e5fd5e 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4126,6 +4126,34 @@  (define-public python-gpytorch
      "GPyTorch is a Gaussian process library implemented using PyTorch.")
     (license license:expat)))
 
+(define-public python-botorch
+  (package
+    (name "python-botorch")
+    (version "0.8.5")
+    (source (origin
+              (method git-fetch) ;no tests in PyPI
+              (uri (git-reference
+                    (url "https://github.com/pytorch/botorch")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xa98xy5wx0mf6fx62lx5cy84svi695iwcg4n74z4f9wz60lghsm"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-gpytorch
+                             python-linear-operator
+                             python-multipledispatch
+                             python-pyro-ppl
+                             python-scipy
+                             python-pytorch))
+    (native-inputs (list python-black python-flake8 python-pytest
+                         python-pytest-cov python-sphinx))
+    (home-page "https://botorch.org")
+    (synopsis "Bayesian Optimization in PyTorch")
+    (description
+     "BoTorch is a library for Bayesian Optimization built on PyTorch.")
+    (license license:expat)))
+
 (define-public vosk-api
   (let* ((openfst openfst-for-vosk)
          (kaldi kaldi-for-vosk))