diff mbox series

[bug#63621,5/6] gnu: Add python-yappi.

Message ID 20230521030210.1282819-5-monego@posteo.net
State New
Headers show
Series Add PyTorch-related statistics libraries. | expand

Commit Message

Vinicius Monego May 21, 2023, 3:02 a.m. UTC
* gnu/packages/python-xyz.scm (python-yappi): New variable.
---
 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ee45ab525..c7a31e40a1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3299,6 +3299,30 @@  (define-public python-openpyxl
 standard.")
     (license license:expat)))
 
+(define-public python-yappi
+  (package
+    (name "python-yappi")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "yappi" version))
+              (sha256
+               (base32
+                "1h3zl60pi57ynb3sw7sg2wcn157jwz992y95bv5kcds3qy7msjsh"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-gevent))
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (replace 'check
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (when tests?
+                              (invoke "python" "run_tests.py")))))))
+    (home-page "https://github.com/sumerc/yappi")
+    (synopsis "Yet Another Python Profiler")
+    (description "Yappi is a tracing profiler that is multithreading, asyncio
+and gevent aware.")
+    (license license:expat)))
+
 (define-public python-eventlet
   (package
     (name "python-eventlet")