diff mbox series

[bug#63621,2/6] gnu: Add python-gpytorch.

Message ID 20230521030210.1282819-2-monego@posteo.net
State New
Headers show
Series Add PyTorch-related statistics libraries. | expand

Commit Message

Vinicius Monego May 21, 2023, 3:02 a.m. UTC
* gnu/packages/machine-learning.scm (python-gpytorch): New variable.
---
 gnu/packages/machine-learning.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index de06b4988a..f4b59556bc 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4099,6 +4099,33 @@  (define-public python-linear-operator
 linear algebra routines needed for structured matrices (or operators).")
     (license license:expat)))
 
+(define-public python-gpytorch
+  (package
+    (name "python-gpytorch")
+    (version "1.10")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "gpytorch" version))
+              (sha256
+               (base32
+                "063zzc515xip3d11y21ld47ca3qq0hqs27jgba20l8mzkympijbd"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; This test failed.
+     (list #:test-flags #~'("-k" "not test_deprecated_methods")))
+    (propagated-inputs (list python-linear-operator python-scikit-learn))
+    (native-inputs (list python-coverage
+                         python-flake8
+                         python-flake8-print
+                         python-nbval
+                         python-pytest
+                         python-twine))
+    (home-page "https://gpytorch.ai")
+    (synopsis "Implementation of Gaussian Processes in Pytorch")
+    (description
+     "GPyTorch is a Gaussian process library implemented using PyTorch.")
+    (license license:expat)))
+
 (define-public vosk-api
   (let* ((openfst openfst-for-vosk)
          (kaldi kaldi-for-vosk))