diff mbox series

[bug#63621,6/6] gnu: Add python-ax-platform.

Message ID 20230521030210.1282819-6-monego@posteo.net
State New
Headers show
Series Add PyTorch-related statistics libraries. | expand

Commit Message

Vinicius Monego May 21, 2023, 3:02 a.m. UTC
* gnu/packages/machine-learning.scm (python-ax-platform): New variable.
---
 gnu/packages/machine-learning.scm | 56 +++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 1e34e5fd5e..384c980478 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4154,6 +4154,62 @@  (define-public python-botorch
      "BoTorch is a library for Bayesian Optimization built on PyTorch.")
     (license license:expat)))
 
+(define-public python-ax-platform
+  (package
+    (name "python-ax-platform")
+    (version "0.3.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "ax-platform" version))
+              (sha256
+               (base32
+                "1spyp8wjf0jyh7yf002sl4lc1rwbnzdki9ql9a3nzsyyx602flj8"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; Ignore tests for tensorboard and torchx, which we don't have.
+     (list #:test-flags
+           #~(list "--ignore" "ax/metrics/tests/test_tensorboard.py"
+                   "--ignore" "ax/runners/tests/test_torchx.py"
+                   ;; This test tries to download online data.
+                   "-k" "not test_torchvision_encode_decode")
+           ;; Ax checks for typeguard==2.13.3 which is the version we have,
+           ;; but the version report in typeguard is fault and displays 0.0.0.
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'sanity-check))))
+    (propagated-inputs (list python-botorch
+                             python-ipywidgets
+                             python-jinja2
+                             python-pandas
+                             python-plotly
+                             python-scikit-learn
+                             python-scipy
+                             python-typeguard))
+    (native-inputs (list jupyter
+                         python-beautifulsoup4
+                         python-black
+                         python-flake8
+                         python-hypothesis
+                         python-jinja2
+                         python-jupyter-client
+                         python-mypy
+                         python-nbconvert
+                         python-pyfakefs
+                         python-pyre-extensions
+                         python-pytest
+                         python-pytest-cov
+                         python-sqlalchemy
+                         python-torchvision
+                         python-yappi))
+    (home-page "https://ax.dev/")
+    (synopsis "Adaptive Experimentation Platform")
+    (description
+     "Ax is an accessible, general-purpose platform for
+understanding, managing, deploying, and automating adaptive experiments.
+Adaptive experimentation is the machine-learning guided process of
+iteratively exploring a (possibly infinite) parameter space in order to
+identify optimal configurations in a resource-efficient manner.")
+    (license license:expat)))
+
 (define-public vosk-api
   (let* ((openfst openfst-for-vosk)
          (kaldi kaldi-for-vosk))